Resolved
Systems are back to normal
Monitoring
A hotfix has been rolled out and is monitored in production
Identified
A new authentication mechanism introduced for VM auth is causing auth failures and too aggressive retries cause our server resources to strain resulting in transient failures of other services.