Dispatch time is back to normal again
Resolved
Monitoring
A fix was deployed to make Redis reads more efficient
Investigating
Run dispatch times to VMs are degraded leading to queue build up